ABOUT ME

-

Today
-
Yesterday
-
Total
-
  • JUNGOL/Intermediate_Coder/그래프탐색-BFS/1462 : 보물섬
    코딩 테스트/JUNGOL 2022. 7. 28. 08:35

    Intermediate_Coder/그래프탐색-BFS/보물섬


    문제                                            

    보물섬 지도를 발견한 후크 선장은 보물을 찾아나섰다. 보물섬 지도는 아래 그림과 같이 직사각형 모양이며 여러 칸으로 나뉘어져 있다. 각 칸은 육지(L)나 바다(W)로 표시되어 있다. 이 지도에서 이동은 상하좌우로 이웃한 육지로만 가능하며, 한 칸 이동하는데 한 시간이 걸린다.

     

    보물은 서로 간에 최단 거리로 이동하는데 있어 가장 긴 시간이 걸리는 육지 두 곳에 나뉘어 묻혀있다. 육지를 나타내는 두 곳 사이를 최단 거리로 이동하려면 같은 곳을 두 번 이상 지나가거나, 멀리 돌아가서는 안된다.

    JUNGOL 그래프탐색-BFS 보물섬1

    예를 들어 위와 같이 지도가 주어졌다면 보물은 아래 표시된 두 곳에 묻혀 있게 되고, 이 둘 사이의 최단 거리로 이동하는 시간은 8시간이 된다.

    JUNGOL 그래프탐색-BFS 보물섬2

    보물 지도가 주어질 때, 보물이 묻혀 있는 두 곳 간의 최단 거리로 이동하는 시간을 구하는 프로그램을 작성하시오.

     

    입력 형식                                     

    입력 파일의 첫째 줄에는 보물 지도의 세로의 크기와 가로의 크기가 빈칸을 사이에 두고 주어진다. 이어 L과 W로 표시된 보물 지도가 아래의 예와 같이 주어지며, 각 문자 사이에는 빈 칸이 없다. 보물 지도의 가로, 세로의 크기는 각각 50이하이다.

     

    출력 형식                                     

    첫째 줄에 보물이 묻혀 있는 두 곳 사이를 최단 거리로 이동하는 시간을 출력한다.

     

    입력 예                                        

    5 7
    WLLWWWL
    LLLWLLL
    LWLWLWW
    LWLWLLL
    WLLWLWW

     

    출력 예                                        

    8


    TreasureIsland.h

    #pragma once
    #include <iostream>
    #include <queue>
    #include <vector>
    #include <algorithm>
    
    #include "../../Base.h"
    
    using std::queue;
    using std::vector;
    
    class TreasureIsland : public Base
    {
    private:
    	struct Point
    	{
    		int x, y;
    		int cost;
    
    		Point() : x(0), y(0), cost(0) {}
    		Point(int x, int y, int cost = 0) : x(x), y(y), cost(cost) {}
    	};
    
    	int GetShortestWayToTreasure();
    	int GetCostFromPosition(const Point& startPosition);
    
    protected:
    	void Code() override;
    
    private:
    	const int LIMITED{ 9'999 };
    
    	int xDir[4]{ 0, 0, -1, 1 };
    	int yDir[4]{ -1, 1, 0, 0 };
    
    	int n, m;
    	char map[50][50]{};
    	int costMap[50][50]{};
    };

     

    TreasureIsland.cpp

    void TreasureIsland::Code()
    {
    	std::cin >> m >> n;
    
    	for (int i = 0; i < m; i++)
    	{
    		for (int j = 0; j < n; j++)
    		{
    			std::cin >> map[i][j];
    		}
    	}
    
    	std::cout << GetShortestWayToTreasure();
    }
    
    /// <summary>
    /// 보물이 있을 수 있는 가장 가까운 거리를 반환한다.
    /// </summary>
    /// <returns>보물이 있을 수 있는 가장 가까운 거리</returns>
    int TreasureIsland::GetShortestWayToTreasure()
    {
    	int dist{ 0 };
    
    	for (int i = 0; i < m; i++)
    	{
    		for (int j = 0; j < n; j++)
    		{
    			if (map[i][j] != 'L')
    			{
    				continue;
    			}
    
    			int curDist{ GetCostFromPosition(Point(j, i)) };
    			if (curDist != 9'999 && dist < curDist)
    			{
    				dist = curDist;
    			}
    		}
    	}
    
    	return dist;
    }
    
    /// <summary>
    /// 시작 지점에서 전 맵을 돌아다닐 때 가장 먼 곳의 비용
    /// </summary>
    /// <param name="startPosition">시작 지점</param>
    /// <returns>비용(기본 값:9,999)</returns>
    int TreasureIsland::GetCostFromPosition(const Point& startPosition)
    {
    	for (int i = 0; i < m; i++)
    	{
    		std::fill_n(costMap[i], n, LIMITED);
    	}
    	costMap[startPosition.y][startPosition.x] = 0;
    
    	queue<Point> q;
    	q.push(startPosition);
    
    	while (!q.empty())
    	{
    		Point p{ q.front() };
    		q.pop();
    
    		for (int i = 0; i < 4; i++)
    		{
    			int newX{ p.x + xDir[i] };
    			int newY{ p.y + yDir[i] };
    
    			if (0 <= newX && newX < n && 0 <= newY && newY < m
    				&& map[newY][newX] == 'L'
    				&& p.cost + 1 < costMap[newY][newX])
    			{
    				costMap[newY][newX] = p.cost + 1;
    				q.push(Point(newX, newY, p.cost + 1));
    			}
    		}
    	}
    
    	int cost{ 0 };
    	for (int i = 0; i < m; i++)
    	{
    		for (int j = 0; j < n; j++)
    		{
    			if (costMap[i][j] != LIMITED)
    			{
    				cost = std::max(cost, costMap[i][j]);
    			}
    		}
    	}
    
    	return cost;
    }

     


    실행 결과 Success(100)


     

    코드 해설

    먼저 기존 코드들과 달리 함수에 전달하는 변수의 수를 줄이기 위해 멤버 변수를 활용했다.

    private:
    	const int LIMITED{ 9'999 };
    
    	int xDir[4]{ 0, 0, -1, 1 };
    	int yDir[4]{ -1, 1, 0, 0 };
    
    	int n, m;
    	char map[50][50]{};
    	int costMap[50][50]{};

     

    이 문제에서 중요한 점은 각 지점에서 다른 지점의 거리가 아니라 한 지점에서 다른 지점까지의 모든 거리 중 가장 먼 지점을 찾는 것이다.

     

    다시 말해 두 지점을 선정해 각각의 거리를 찾을 필요 없이 한 지점에서 시작해 이동 가능한 위치를 모두 이동하며 비용을 계산한 뒤 마지막에 가장 큰 값을 반환하면 된다는 것이다.

     

    다음 코드에서 한 지점에서 이동하며 방문한 모든 지점의 비용을 저장한다.

    	while (!q.empty())
    	{
    		Point p{ q.front() };
    		q.pop();
    
    		for (int i = 0; i < 4; i++)
    		{
    			int newX{ p.x + xDir[i] };
    			int newY{ p.y + yDir[i] };
    
    			if (0 <= newX && newX < n && 0 <= newY && newY < m
    				&& map[newY][newX] == 'L'
    				&& p.cost + 1 < costMap[newY][newX])
    			{
    				costMap[newY][newX] = p.cost + 1;
    				q.push(Point(newX, newY, p.cost + 1));
    			}
    		}
    	}

     

    이후 방문했던 지점 중 가장 비용이 큰 값을 결과로 저장한다.

    	int cost{ 0 };
    	for (int i = 0; i < m; i++)
    	{
    		for (int j = 0; j < n; j++)
    		{
    			if (costMap[i][j] != LIMITED)
    			{
    				cost = std::max(cost, costMap[i][j]);
    			}
    		}
    	}

     

    이런 식으로 모든 육지에 대해서 반복해서 가장 작은 값을 결과로 선택하면 된다.

    	for (int i = 0; i < m; i++)
    	{
    		for (int j = 0; j < n; j++)
    		{
    			if (map[i][j] != 'L')
    			{
    				continue;
    			}
    
    			int curDist{ GetCostFromPosition(Point(j, i)) };
    			if (curDist != 9'999 && dist < curDist)
    			{
    				dist = curDist;
    			}
    		}
    	}

     

    NadanKim/CodingTest_JUNGOL: JUNGOL 코딩 테스트를 위한 저장소 (github.com)

     

    NadanKim/CodingTest_JUNGOL

    JUNGOL 코딩 테스트를 위한 저장소. Contribute to NadanKim/CodingTest_JUNGOL development by creating an account on GitHub.

    github.com

     

    댓글

Designed by Tistory.